+-


Alarm Monitoring

Alarm Monitoring

Members Online

73 Guests, 0 Users

Alarm Installer Search and Reviews




Myalarminstaller.com

Author Topic: Vista-20P w/ 6150RF no display  (Read 1653 times)

jjbeard926

  • Member
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Vista-20P w/ 6150RF no display
« on: April 29, 2008, 06:48:05 AM »
Hello, newbie here. I didn't see anything like this doing a search through the forum, I apologize if it's already been answered here. I've installed one other security system and now I'm installing a Vista 20p with a 6150RF keypad. First the setup:
Vista 20p wired to the keypad using gauge 16 wire 11 ft. away. The Vista is powered using gauge 14 wire which isn't approved in the manual but customer support from Honeywell said would work for power but now they wont talk to me because I'm not a reseller.

The error I'm getting isn't listed in the manuals at all. I get power to the keypad but no display. The LEDs are lit, if I press the buttons I get responsive beeps but no display. I powered on the system and pressed * and # at the same time to enter program mode and got a beep from the keypad. Then I wait up to a minute and it starts beeping about once every 20 seconds. The control panel has an RF receiver 5881 installed and the LED on it blinks in the correct pattern to show that it is working but receiving no signals. I also know that the display on the 6150 is not broken because when I first set this up a connection was loose and it displayed OC for an open circuit.

Any ideas on what this could be?  Thanks in advance.

murphy62

  • Security Guru
  • ****
  • Posts: 1598
  • Karma: +23/-0
    • View Profile
Re: Vista-20P w/ 6150RF no display
« Reply #1 on: April 29, 2008, 06:58:38 AM »
Did you set the keypad to address 16?
Press the 1 and 3 keys for 3 seconds and it will display it's current address.
The default is 31, which won't work.

jjbeard926

  • Member
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Vista-20P w/ 6150RF no display
« Reply #2 on: April 29, 2008, 07:26:50 AM »
Thank you. I can't believe I overlooked that. It was staring me right in the face.

 

Powered by EzPortal